Failure to communicate with HP equipment when adding to MF
Fail
When adding the device to NDD Print MF HP, the message “Device did not respond to the compatibility test. User and password data may be incorrect”.
Cause
The Server where the MF was installed has a Proxy activated, blocking the HTTP and HTTPS calls that the MF makes to validate the device's information.
Solution
Initially, we opened the internet settings to check if the Proxy was configured, and it wasn't enabled.
It was necessary to access the Windows registry to disable the Proxy.
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"MigrateProxy"=dword:00000001
"ProxyEnable"=dword:00000001
"ProxyHttp1.1"=dword:00000000
"ProxyServer"="http://ProxyServername:80"
"ProxyOverride"="<local>"
Change the “ProxyEnable” key to the value “0”.
Other information
The fault was identified in the HP Color Laser Jet Flow E67560.
In the Test Configutarion tool, when we tried to make the Get discovery tree call, the failure Error: “Error accessing DiscoveryTree.xml: StackTrace: in OXPd: Domain.ServiceDiscovery.DicoveryTreeTranslator.GetOXPdDiscoveryTree(String hostname, int 16 port, Boolean use HTTPS) in TestConfigurations.FrmTestConfigurations.GetDiscoveryTree()” was displayed.
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